After Upgrade to DNN 7.2 dnnMenu DISPLAY:NONE

Dec 21, 2013 at 11:08 PM
I've been using your great skin for a while now since DNN 7.0. I upgraded to DNN 7.1 without any problems. However, when I upgraded to DNN 7.2, dnnMenu disappeared. Inspecting the element, I can see that the dnnMenu is set to DISPLAY:NONE. It is only behaving correctly when an ADMIN is logged in. Otherwise, ordinary user experiences the same behavior. I'm guessing some scripts in the background is doing this. As I'm not a programmer, I'm quite in a loss how to go about this. Any help would be very much appreciated.

Here is the site -

Dec 22, 2013 at 7:53 PM
Hi Olan,

When I access your site the menus seem to be working correctly on both desktop and mobile. Did you resolve this issue on your own? If so, please share.


Dec 22, 2013 at 9:14 PM
Sorry, but i had to downgrade from a backup to DNN 7.1.2 again a couple of hours ago or so. Another site in the same instance/installation is affected.
I'll try to google around for similar case and try to move forward. I made a backup after DNN 7.2.0. So it'll be easy in case i find a solution soon.
Tnx for coming back on this case, olan
Dec 22, 2013 at 11:13 PM
Hi Olan,

I grabbed the latest bits for DNN 07.02.00 (607) and wasn't able to duplicate this issue. Perhaps it's an upgrade bug? Could you possibly install your 7.2 site on a sub-domain? Or somewhere I could debug the CSS to see what is causing your issue?


Dec 23, 2013 at 4:10 PM
Hi Adam,
I upgraded DURAN.PH to DNN 07.02.00 (607) anew and the behavior is still the same. I'll leave until you have the chance to debug it.
I put a Maintenance Page temporarily for the other site.

Thanks once more for the support,
Dec 23, 2013 at 6:23 PM
Hi Olan,

I think I've found a fix for your bug.

In js/tidy.js replace Line 6-13 with the following code:
// Mobile Menu Show and Hide
$( "#mobileMenuBtn" ).click(function() {
    if ($('#dnnMenu').is(':hidden')) {
    } else {
Give that a shot and let me know if it fixes your menu issues.


Marked as answer by adamhumphrey on 12/23/2013 at 12:51 PM
Dec 23, 2013 at 7:06 PM
Super thanks Adam! It is working!
The other site is online as well again.

Thanks for the early Christmas present.
Have a blessed Christmas and New Year!